Demo & Step by Step Guide

Self Service Business
Intelligence with a Tool End
Users Already Know & Love

By: Wylie Blanchard - Great Tech Pros

Analyze & Present Data with Power Pivot &
PowerView

Activate Power Pivot MS Excel add-in

Open MS Excel 2013\2016

Go to File > Options > Add-Ins

In the Manage box, click COM Add-ins> Go

Check the Microsoft Office Power Pivot & Power View boxes

poON =



COM Add-Ins ? X

Add-Ins available:
[ linquire . )
:\Zl Microsoft Office PowerPivot for Excel 2013 tancal

|| Microsoft Power Map for Excel
Z‘ Power View

[_]Team Foundation Add-in e
Remove
Location: C\Program Files\Microsoft Office 15\Root\Office15\ADDINS\PowerPivot Excel Add-in\PowerPivotExcelClientAddin.dll
Load Behavior: Load at Startup
Excel 2013
COM Add-ins ? X

Add-ins available:

% Inquire
__| Microsoft Power Mai for Excel Cancel

Microsoft Power View for Excel Add
Team Foundation Add-in =
Team Foundation Add-in

Remove

Location: C:\Program Files\Microsoft Office\Root\Office 16\ADDINS\PowerPivot Excel Add-in\PowerPivotExcelClientAddindll

Load Behavior: Load at Startup

Excel 2016

Power Pivot tab

1. Click the Power Pivot tab
a. This is the tab where you work with Power Pivot PivotTables, calculated fields,
and key performance indicators (KPIs), and creating linked tables
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2. Click Manage to open the Power Pivot window
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Import Data from SQL Server

1. Inthe Power Pivot window, click Get External Data > From Database > From SQL
Server

2. In Connect to Microsoft SQL Server Database, in Server or File Name, enter the
name of SQL Server instance where your Data Warehouse is located.

3. Click the down arrow to the right of the Database name list, and select an Analysis
Services database from the list

4.  Click Test Connection to verify that the server is available.

5. Click Next



Table Import Wizard ? X

Connect to a Microsoft SQL Server Database
Enter the information required to connect to the Microsoft SQL Server database

Friendly connection name: !SqIServar LAPTOP-P3AJK7V7 HealthCareCCCD

Server name: [LAPTOP-P3AJK7V7 v]

Log on to the server

(®) Use Windows Authentication

(O Use SQL Server Authentication

User name: |

Password: |

Database name: HeaMCareCCCD v

Advanced Test Connection

< Back | Next > | Finish Cancel

On the Choose How to Import the Data screen click the radial button for Select from a
list of tables and views to choose the data to import
Click Next
Select the tables and views that you want included.
a. You can change any Source Table name to Friendly Name
b.  You can click Preview and Fliter to exclude columns and data
Click Finish to complete import process



Table Import Wizard ? X

Select Tables and Views
Select the tables and views that you want to import data from.

Server: LAPTOP-P3AJK7V7
Database: HealthCareCCCD

Tables and Views:

C Source Table Schema Friendly Name Filter Details A

[J=  EDWPHARM dbo

[]= | EDWPROCE dbo

[]= EDWREVEN dbo

(= | eEDwsNiPs dbo

[]= P1BPDDK? dbo

[]=  P1BPDK7-COS dbo

[J=  P1BPDK7-ESC dbo.

[ Jm | P1BPDK7-PT dbo

(& | claim | dbo

[]&@  Doctor dbo

@  MedicalClaim dbo Claim

&  MedicalPatient dbo Patient

V] @ | MedicalProvider dbo | Provider
# | Patient

| v

‘ Select Related Tables | ‘ Preview & Filter
/|

o [ [om ]| o



Table Import Wizard

Importing

The import operation might take several minutes to complete. To stop the import operation,

click the Stop Import button.

Q Total: 3 Cancelled: 0
Success
Success: 3 Error: 0
Details:
| Work ltem Status Message
& Claim Success. 375,728 rows transferred.
@ Patient Success. 51 rows transferred.
@ Provider Success. 51 rows transferred.

Completed Data Import (below)

top Import Close |
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Save the Model Project

It is important to frequently save your model project.

To save the model project
e [n SQL Server Data Tools, click on the File menu, and then click Save All.

Review Existing Relationships and Add
New Relationships

A relationship is a connection between two tables that establishes how the data in those tables
should be correlated. For example, the Product table and the Product Subcategory table have a
relationship based on the fact that each product belongs to a subcategory.

When you imported data by using the Table Import Wizard, you imported seven tables from the
AdventureWorksDW database. Generally, if you import data from a relational source, existing
relationships are automatically imported together with the data. However, before you proceed
with authoring your model you should verify those relationships between tables were created
properly. For this tutorial, you will also add three new relationships.

To add new relationships between tables
1. In the model designer, in the Provider table, click and hold on the ProviderID column,
then drag the cursor to the Claim column in the Provider table, and then release.
a. A solid line appears showing you have created an active relationship between
the ProviderlID column in the Provider table and the ProviderlD column in the
Claim table.
2. In the Patient table, click and hold on the RecipientID column, then drag the cursor to
the RecipientlD column in the Claim table, and then release.
a. A dotted line appears showing you have created an inactive relationship between
the RecipientID column in the Patient table and the RecipientID column in the
Claim table. You can have multiple relationships between tables, but only one
relationship can be active at a time.
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View

1. Using the top Ribbon, click Home, under the View section click Diagram View.
a. The model designer now appears in Diagram View, a graphical format displaying
all of the tables you imported with lines between them. The lines between tables
indicate the relationships that were automatically created when you imported the

data.

b. Use the minimap controls in the lower-right corner of the model designer to
adjust the view to include as many of the tables as possible. You can also click
and drag tables to different locations, bringing tables closer together, or putting
them in a particular order. Moving tables does not affect the relationships already
between the tables. To view all of the columns in a particular table, click and drag

on a table edge to expand or make it smaller.

Create a Calculated Column

A calculated column is a column created by a dax formula that creates a value by calculating
data that already exists in the model.

Create a calculated column in the Provider table
1. sing the top Ribbon, click Home, under the View section click Data View.



a. Calculated columns can only be created by using the model designer in Data
View.
2. In the model designer, click the Provider table (tab).
3. Right-click the Add Column column header, and then click Insert Column.

cate [ 2oCode [ 7
VA

98011 'E Insert Column
VA 98011 _ Rename Column
VA 98011
VA 98011
VA 98011
VA 98011
VA 98011
VA 98011
VA 98011

4. A new column named Calculated Column 1 is inserted to the right of the ZipCode
column.

5. Inthe formula bar above the table, type the following formula. AutoComplete helps you
type the fully qualified names of columns and tables, and lists the functions that are
available.

a. =[Title]&" "&[FirstName]&" "&[LastName]

b. When you have finished building the formula, press ENTER.

c. Values are then populated for all the rows in the calculated column. If you scroll
down through the table, you will see that rows can have different values for this
column, based on the data that is in each row.

6. Rename this column to FullName.



[FullNa... -

1 036044607
2 036123417
3 036110272
4 399447366
5 036106249
6 036112278
7 036058775
8 036079981
9 036066171
10 036041603
11 036066410
12 036049731
13 036087664
14 036066429
15 264319386

Create a Measure
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Dr
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1399 Firestone ...
250 Race Court
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Dr Zenzi Zenzi

Dr John Stewart
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Dr Samuel Wilson
Dr Shuri Shuri

Dr Martha Washington
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Dr Tetu Tetu
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Dr Jennifer Pierce

Similar to the calculated columns you created in the previous lesson, a measure is essentially a

calculation created using a DAX formula. However, unlike calculated columns, measures are

evaluated based on a user selected filter; for example, a particular column or slicer added to the
Row Labels field in a PivotTable. A value for each cell in the filter is then calculated by the

applied measure. Measures are powerful, flexible calculations that you will want to include in

almost all tabular models, to perform dynamic calculations on numerical data.

To create a Daily Average Number of Claims measure in the Claim table
1. Click the Claim table(tab).

2. In the measure grid (lower pane under the dark grey line), click the top-left empty cell.

3. Inthe formula bar, above the table, type the following formula:
a. Total Claims:=DISTINCTCOUNT([DCN])

b. When you have finished building the formula, press ENTER.

4. Create a second measure in the below cell, type the following formula:
a. Daily Avg Claims:=[Total Claims]/DISTINCTCOUNT([AdjudicatedDt])

b. When you have finished building the formula, press ENTER.
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Total Claims: 357477
|Daily Avg Claims: 156.171690694626 |

<

Claim_ Patient = Provider
—

5. You can format the numeric measure value by the right clicking the cell and selecting

Format.
‘4 201400000099722 01 N

Total Claims: 357477

|Daily Avg Claims: 156.17169069462¢ Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Delete Del

| Create KPI...

laim | Patient | Provider |
T T

6. Once the Formatting Window opens you can then specify how you want to display the

Hide from Client Tools

Format...

Manmrimbime

numeric value. For our example we utilize the Decimal Number format and then specify
the number of decimal places.

Category:
|General A~ | Format
:Currency V| Decimal places:

Decimal Number

2

[ Use 1000 separator ()

6. Click Ok.

-
-

Cancel
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Total Claims: 357477

Daily Avg Claims: 156.17

Create Key Performance Indicators

Key Performance Indicators (KPIs) are used to gauge performance of a value, defined by a
Base measure, against a Target value, also defined by a measure or by an absolute value. In
reporting client applications, KPIs can provide business professionals a quick and easy way to
understand a summary of business success or to identify trends.

To create a Daily Average Claim Performance KPI

1.
2.

No o bk

In the model designer, click the Claim table (tab).
In the measure grid, right-click the Daily Avg Claims measure, and then click Create
KPI.
a. The Key Performance Indicator dialog box opens.
In the Key Performance Indicator (KPI) dialog box, in Target, select the
Absolute Value option.
In the Absolute Value field, type 15, and then press ENTER.
In the left (low) slider field, type 6, and then in the right (high) slider field, type 12.
In Select Icon Style, select the first (red), (yellow), (green) icon type.
Click OK to complete the KPI.
a. Inthe measure grid, notice the icon next to the Internet Current Quarter Sales
Performance measure. This icon indicates that this measure serves as a Base
value for a KPI.
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KPI base field (value):  Daily Avg Claims
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Create a Hierarchy

Hierarchies are metadata that define relationships between two or more columns in a table, thus
defining the relative position of column to another column.

To create a Category hierarchy in the Patient table

1.
2.

3.

Using the top Ribbon, click Home, under the View section click Diagram View.
Right-click the Patient table, and then click Create Hierarchy. A new hierarchy appears
at the bottom of the table window.

In the hierarchy name, rename the hierarchy by typing PatientLocation, and then press
ENTER.

In the Patient table, right click the State column, in the pop up box go to Add to
Hierarchy and then click Locations.

In the Patient table, click the City column, then drag it to the Locations hierarchy,
releasing it below State.

In the Patient table, click the ZipCode column, then drag it to the Locations hierarchy,
releasing it below City.



7. In the Patient table, click the Address column, then drag it to the Locations hierarchy,
releasing it below ZipCode.

8. In the Locations hierarchy, right-click the State column, then click Rename, and then
type StateProvince.

9. Note: Ensure that the columns in the hierarchy are in logical order. Typically the column
with the least uniqueness (based on business) should be near the top of the list and the
column with the highest uniqueness (based on the business) should be near the bottom
of the list.

7] Patient BE

_______ City
1] State
7] ZipCode
7] HomePhone
7] WorkPhone
7] MobilePhone
4 13 PatientLocation
StateProvince (...
City (City)
ZipCode (ZipCo...

Create a PivotTable

1. While in PowerPivot click the PivotTable button
2. Onthe Create PivotTable screen select New Worksheet
a. A new PivotTable Worksheet is created
3.  Under PivotTable Fields do the following
a. Goto Provider. Select FullName.
b. Go to Patient. Select PatientLocation.
c. Goto Claim > Daily Avg Claims, Select Value and Status.
4. Give it a title
5. Complete. You've created a PivotTable

Note: Use the Filters pane (in PivotTable Fields pane) to only display specific data that you
want shown in yourPivotTable.
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Create a Power View Workbook

1. Navigate back to your excel workbook to display your previously created PivotTable
2. Using the top Ribbon, go to Insert and then click the Power View button
3. Excel creates a Power View Sheet with your data model in the Field List
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4. Inthe Power View Fields list do the following
a. Go to Patient. Select FullName.
b. Go to Claim > Daily Avg Claims, Select Value and Status.
Go to Design, (In the Switch Visualizations section) go to Other Chart and Select Pie.
Go to Layout, (In the Labels section) go to Title and Select None.
Drag the edges of the Chart so that it spaced across the top half of the pane.
Right Click the white space within the chart and click Copy. Then Right Click the white
space below the chart and select Paste.
9. Go to Design, (In the Switch Visualizations section) go to Column Chart and Select
Clustured Column.

Filter the data

® N O

1. In the Power View Fields Pane, Go to Claim and find Year
2. Drag Year to the Filters pane
a. Year will now display in the Filters pane
Filters ¢ X
WVIEW

4 Year = | x

2005 2015



3. Click on the Advanced Filter Mode button next to Year in
the Filter pane

4. Select radial box with the most current year

5. The Power View displays the charts for the most current
year

6. Click where it says, “Click here to add a title” and give it a
title.

7. Complete, you've created a Power View report.

Note: Interactivity: By clicking on any part of either chart, the
visualization will interact and react to your selection by
highlighting/emphasizing your specific

Note: Interactivity: Direct your mouse/pointer to any portion of your

chart - PowerView will display additional data about that specific section

Note: You can change or add to the view by making additional selection from the Power View

Fields pane
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